Problem with Libtool-1.5

Tushar Teredesai tushart at abbnm.com
Wed May 28 07:47:55 PDT 2003


Greg Schafer wrote:

>The breakage is caused by the rerunning of the autotools. What is happening
>is this:-
>
> - the BLFS patch touches various autotools files that force them to be
>   rebuilt
>   
> - part of this rerunning involves running aclocal
>
> - aclocal recreates aclocal.m4 (it's programmed to look at
>   /usr/share/aclocal which, lo & behold, contains libtool.m4 from the
>   libtool-1.5 package!)
>
> - we now have a mismatch coz the ltmain.sh in the fam tarball is version
>   1.4 but the aclocal.m4 was created from the 1.5 m4 file. This is broken,
>   broken, broken!
>
>The fix is to run:
>
>  libtoolize --force
>
>imediately after applying the fam patch.
>
>The whole concept of relying on the autotools to rebuild the necessary files
>is a BROKEN idea! At least from our package builders POV. It's certainly a
>nice feature for developers actively devloping code, but for us pkg
>builders, it cannot work reliably. BLFS must address this!
>  
>
Thanks. Have added it to blfs-bugzilla. I had been doing the same thing 
in my build scripts for a long time.

-- 
Tushar Teredesai
  E-mail:    tushartATabbnmDOTcom
  Extension: 5267


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list