Shadow 4.0.4.1 regression against 4.0.3

Greg Schafer gschafer at zip.com.au
Sun Jan 18 14:13:14 PST 2004


On Sun, Jan 18, 2004 at 05:25:19PM +0500, Alexander E. Patrakov wrote:
> The sad fact is that internationalization is broken in Shadow 4.0.4.1.

<snip>

Thanks for that.

> For now, we (LFSers) can work around this bug (and also around the PAM linkage 
> bug) with the following instructions (no patches are needed):
> 
> CFLAGS="-O2 -pipe -DHAVE_SETLOCALE" LIBS="-lpam -lpam_misc" \
> 	./configure --prefix=/usr --libdir=/usr/lib --enable-shared --with-libpam
> make
> make install

Umm, sorry. Setting CFLAGS in the LFS book is (currently) unacceptable. Maybe
something like this would work:

after the run of configure

echo '#define HAVE_SETLOCALE 1' >> config.h

> Also note that since this release does not contain debian/securetty file 
> handy, we (LFSers) have to create /etc/securetty file ourselves.

the LFS book doesn't deal with this file so no biggie.



More information about the lfs-dev mailing list