Change to glibc build instructions -- RFC

Thomas Beneke thomas.beneke at web.de
Tue Jul 27 03:24:13 PDT 2004


Jim Gifford wrote:
> After a few discussions with Kevin and Ryan, about our current glibc 
> build I believe we need to make the following changes to it.
> 
> Add --with-__thread, this will fix a glibc issue with --with-tls.
> Add -" this will make the glibc specific to the 2.6 
> build (can be enable-kernel=2.4 for 2.4.x builds)
> 
> Remove pt_chown removal -- This is still required by programs, don't 
> know why it was removed.
> 
> This change may add a failure to the test suite, but I'm still checking 
> that out.
> 
> I have posted the updated pages for view at my web site.
> 
> http://documents.jg555.com/lfs/chapter05/glibc.html
> http://documents.jg555.com/lfs/chapter06/glibc.html
> 
If you use "-enable-kernel=2.6.0" you will never be able to use 
precompiled software like plugins for mozilla, staroffice or Oracle.

Regards,
Thomas



More information about the lfs-dev mailing list