LFS Boot Cd

James Robertson jwrober at linuxfromscratch.org
Wed Jul 28 19:19:52 PDT 2004


Jeremy Huntwork wrote:

> Thanks in advance for the feedback!
> 

Notes from first boot.  I have not tried to do any building yet.  The 
host (if you can believe, don't shoot me) is a Microsoft Virtual PC 2004 
session.  I have it on my work computer and deciced to start there 
'cause it was handy.  I used the 800 option to start 2.4.26 kernel using 
vesa fb @ 800x600.

1.  Before init starts, the kernel tried to load an aic7xxx module and 
fails.  VPC sessions have no SCSI devices in them.  The error inside a 
'dmesg | less' command says:

kmod: failed to execute /sbin/modprobe -s -k scsi_hostadapter, error = 2

2.  Also, the kernel tried to load a 3c59x driver and failed.  I could 
not find a corresponsding message in the log.

3.  Looks like you are using a older bootscripts package that does not 
have the console and setfont script.  If you choose a FB console, to get 
rid of the penguin at the top, you need to run setfont.

4.  If we want a potential user to be able to follow the book 
explicitly, then /mnt needs to be writable somehow so a /mnt/lfs dir and 
mount point can be used.

5.  /etc/mtab is empty even though /etc/fstab mounts /proc and /dev/pts.

6.  The list of old style devices seems light.  Probably a base 
make_devices script run.  Is this enough for a multi-purpose boot cd?

7.  The / filesystem is RO and so you cannot create a symbolic link 
/tools there.

Now for things I liked:

1.  I love the boot splash screen at the lilo prompt.  Very nice.

2.  The modules that did come up enabled a lot of my hardware that I 
needed - nic for one and dhcp did not flinch.

3.  I like the greeting and lynx setup.

More later when I try on real hardware and attempt a 5.1.1 stable build.

James







More information about the lfs-dev mailing list