LFS Boot Cd

Jeremy Utley (-J-), LFS Staff jeremy at linuxfromscratch.org
Wed Jul 28 19:41:10 PDT 2004


> Jeremy Huntwork wrote:
>
>> Thanks in advance for the feedback!
>>
>
> Notes from first boot.  I have not tried to do any building yet.  The
> host (if you can believe, don't shoot me) is a Microsoft Virtual PC 2004
> session.  I have it on my work computer and deciced to start there
> 'cause it was handy.  I used the 800 option to start 2.4.26 kernel using
> vesa fb @ 800x600.
>
> 1.  Before init starts, the kernel tried to load an aic7xxx module and
> fails.  VPC sessions have no SCSI devices in them.  The error inside a
> 'dmesg | less' command says:
>
> kmod: failed to execute /sbin/modprobe -s -k scsi_hostadapter, error = 2

Not unheard of - even some of my desktop kernels do this.  It's really a
non-issue.

>
> 2.  Also, the kernel tried to load a 3c59x driver and failed.  I could
> not find a corresponsding message in the log.

Did Jeremy perhaps compile 3c59x into the kernel rather than as a module?

>
> 3.  Looks like you are using a older bootscripts package that does not
> have the console and setfont script.  If you choose a FB console, to get
> rid of the penguin at the top, you need to run setfont.

I *LIKE* the penguin!

>
> 4.  If we want a potential user to be able to follow the book
> explicitly, then /mnt needs to be writable somehow so a /mnt/lfs dir and
> mount point can be used.

Chris's bootcd (and mine) works around this by mounting a tmpfs
filesystem, symlinking a lot of stuff from the CD into this, then
pivot_rooting.  That way, many areas of the cd are writeable.

>
> 5.  /etc/mtab is empty even though /etc/fstab mounts /proc and /dev/pts.

Easiest way around this one is to symlink /etc/mtab to /proc/mounts - it
breaks things slightly, but not enough to really matter.

>
> 6.  The list of old style devices seems light.  Probably a base
> make_devices script run.  Is this enough for a multi-purpose boot cd?

Chris's and mine use devfs, except his newest one which uses udev. 
Something like this, imho, is important for a bootcd.

>
> 7.  The / filesystem is RO and so you cannot create a symbolic link
> /tools there.

Solved by the tmpfs we used above.

-J-



More information about the lfs-dev mailing list