LFS Boot Cd

James Robertson jwrober at linuxfromscratch.org
Thu Jul 29 06:47:39 PDT 2004


Jeremy Huntwork wrote:
> On Wed, 2004-07-28 at 21:19 -0500, James Robertson wrote:
> 
>>Jeremy Huntwork wrote:
>>
>>>Thanks in advance for the feedback!
> 
> 7 Cons and 3 Pro?  eek.

And as you work on your repeatable process, the cons will shrink and the 
pros will get better!  (I am always an optimist)

>>1.  Before init starts, the kernel tried to load an aic7xxx module and 
>>fails.  VPC sessions have no SCSI devices in them.  The error inside a 
>>'dmesg | less' command says:
>>
>>kmod: failed to execute /sbin/modprobe -s -k scsi_hostadapter, error = 2
> 
> I wasn't sure how to handle this one.  I use a linuxrc script as init,
> then pivot_root to the cd, chroot and finally run /sbin/init. One of my
> systems is SCSI oriented, including SCSI cd's. So unless I load the SCSI
> module in the linuxrc, the script can't find the cd and is unable to
> pivot_root. :( Also, I figured at that point I'd load a 3com module, and
> tulip so that the dhcp script won't always fail utterly.  I suppose I
> could have built those two drivers into the kernel...

I understand.  I was going to try tonight in a 100% SCSI box and see 
what hapened as well.  Like I mentioned, that was my very first boot 
with the CD.  I am not sure it matters that you put more stuff into the 
kernel directly.  You have plenty of space.

>>2.  Also, the kernel tried to load a 3c59x driver and failed.  I could 
>>not find a corresponsding message in the log.
> 
> Yeah, see above.  I don't know much about modules - I tried to quiet the
> error messages if the module fails, but with no success.

OK.  I have issues with them too.  I do better with non-modular kernels 
myslef, but that won't work in this case.

>>3.  Looks like you are using a older bootscripts package that does not 
>>have the console and setfont script.  If you choose a FB console, to get 
>>rid of the penguin at the top, you need to run setfont.
> 
> The cd is entirely built on a 5.1.1 stable base - so it has those
> bootscripts.

OK.

>>4.  If we want a potential user to be able to follow the book 
>>explicitly, then /mnt needs to be writable somehow so a /mnt/lfs dir and 
>>mount point can be used.
> 
> Thanks, missed that one.
> 
>>5.  /etc/mtab is empty even though /etc/fstab mounts /proc and /dev/pts.
> 
> hmmm.  That's funny, because /etc is writable.

I noticed that too.  Interesting...

>>6.  The list of old style devices seems light.  Probably a base 
>>make_devices script run.  Is this enough for a multi-purpose boot cd?
> 
> It was a base script, with a couple of additions - I'll most likely be
> moving to udev...

Does udev work with 2.4.x kernels? I have no experience with it, only devfs.

>>7.  The / filesystem is RO and so you cannot create a symbolic link 
>>/tools there.
> 
> Again, thanks. Missed that one... Though I don't know that I want to
> make the entire / directory writable... hmmm.

It looked like Jeremy U had some ideas.  Will any of those work?

>>Now for things I liked:
>>
>>1.  I love the boot splash screen at the lilo prompt.  Very nice.
> 
> Oh, thanks. Just goofing around...
> 
>>2.  The modules that did come up enabled a lot of my hardware that I 
>>needed - nic for one and dhcp did not flinch.
> 
> That must have been the tulip module.

I am not familiar with "tulip", but it worked on the DEC Nic that comes 
with the VPC session.

>>3.  I like the greeting and lynx setup.
> 
> Thanks. That sprang out of trying to make things as easy as possible for
> a couple of friends of mine...
> 
>>More later when I try on real hardware and attempt a 5.1.1 stable build.
> 
> Okay, thanks.  From the looks of things, I may need to start anew ;)

I don't know about that.  You have a good base that just needs some 
modifications.  You do have a repeatable process written down or 
scripted - right?  That is the key with stuff like this.  I make is very 
easy for you to modify and do another run.

James



More information about the lfs-dev mailing list