SVN repsoitory now live

Bryan Kadzban bryan at kadzban.is-a-geek.net
Thu Jun 24 14:37:08 PDT 2004


Anderson Lizardo wrote:
> I tried to checkout anonymously with
> 
> svn co http://svn.linuxfromscratch.org/repos/LFS/trunk/BOOK LFS
> 
> But it didn't work (well, it worked right after you announced the svn
>  repository availability, but not now):
> 
> svn: PROPFIND request failed on '/repos/LFS/trunk/BOOK'
> svn: PROPFIND of '/repos/LFS/trunk/BOOK': 405 Method Not Allowed 
> (http://svn.linuxfromscratch.org)

IIRC, Matthew said that HTTP (aka WebDAV) access to the SVN repository
was not going to be turned on (the Method Not Allowed may be due to your
svn client using the WebDAV-specific HTTP method of PROPFIND).

> I then managed to checkout only with:
> 
> svn co svn://svn.linuxfromscratch.org/LFS/trunk/BOOK LFS

I believe that's the recommended protocol for remote users at least.

> Another problem: I can't use file protocol to checkout on belgarath:
> 
> $ svn co file:///home/svn/repositories/LFS/trunk/BOOK LFS
> svn: Unable to open an ra_local session to URL
> svn: Unable to open repository
> 'file:///home/svn/repositories/LFS/trunk/BOOK'
> svn: Berkeley DB error while opening environment for filesystem
> /home/svn/repositories/LFS/db: Permission denied

Don't know on that one for sure, but does the svn:// protocol work
locally also?



More information about the lfs-dev mailing list