5.1 Release Criteria

Matthew Burgess matthew at linuxfromscratch.org
Tue May 4 13:22:20 PDT 2004


On Tue, 4 May 2004 14:11:49 -0600 (MDT)
"Nathan Coulson" <conathan at conet.dyndns.org> wrote:

> > On Tue, 4 May 2004 14:04:01 -0600 (MDT)
> > "Nathan Coulson" <conathan at conet.dyndns.org> wrote:
> >
> >> 2.0.5 is 2.0.4 with the heimdal script in it (AKA, no changes when
> >it> comes to LFS).  It should be added for BLFS's sake.
> >
> > Ack, why are BLFS scripts in a LFS-Bootscript tarball?  Sorry if I
> > missed the previous discussion on this, but doesn't it just create
> > an unnecessary dependency between the two projects?
> >
> > Cheers,
> >
> > Matt.
> > --
> 
> Tushar requested it. more or less we have a seperate install target,
> such as make install-sshd to install the sshd scripts.
> 
> it's been that way for a couple months now.  [since 2.0.2 or .3 I dont
> recall].

Fair enough.  In the future when we call a package freeze then this will
apply to the bootscripts package as well, but for now you're free to
update it on 2 conditions a) It doesn't touch any of the LFS scripts and
b) The BLFS guys OK the changes to their scripts.  I hope you can
understand the need for some kind of configuration management and change
control here.  Let me know as soon as you're done so I can update the
book a.s.a.p.  If this is to work out I think the BLFS & LFS guys need
to declare a package freeze at the same time, in case any of their
packages need new/updated scripts as is the case now AFAIUI.

Cheers,

Matt.



More information about the lfs-dev mailing list