glibc make-error

Jeremy Utley jeremy at jutley.org
Sun May 23 15:18:25 PDT 2004


Robbert Klarenbeek wrote:

> Hi,
>
> I'm building the CVS from 2004-05-10 with Knoppix as my host-system. 
> First I used Knoppix 3.3 (kernel 2.4.25), but I received some errors 
> while building glibc-2.3.4-20040510 for the first time (chapter 5). I 
> then realized piece of text claiming you should build this LFS with at 
> least a 2.6.2 kernel. So I upgraded to Knoppix 3.4, booting with 
> kernel 2.6.5. I actually still receive the same error, I don't know 
> what to do, so now I'm trying this mailing list (1st time using 
> mailing lists, hope this is the right one / right way :-) The last 4 
> lines of the error-message I receive are as follows:
>
> nptl/sysdeps/i386/tls.h:58:3: #error "TLS support is required."
> make[1]: *** [/mnt/hda3/sources/glibc-build/Versions.v.i] Error 1
> make[1]: Leaving directory `/mnt/hda3/sources/glibc-2.3.4-20040510'
> make: *** [all] Error 2
>
> Scrolling up I see a lot of '#error "TLS support is 
> required."'-messages, without make quiting... Is this the error 
> causing my make-failure? If it is, how to solve it? If it isn't, is my 
> host system the problem (I can get a different one) or am I doing 
> something wrong?
>
> Plz help me, thx in advance,
> Robbert
>
> _________________________________________________________________
> MSN Zoeken helpt je om de gekste dingen te vinden! http://search.msn.nl
>
Didn't put --enable-tls in your glibc configure line did you?

-J-




More information about the lfs-dev mailing list