System clock hastening

Jens Olav Nygaard jens_olav.nygaard at chello.no
Wed Aug 10 11:07:52 PDT 2005


Matthew Burgess wrote:
> Jens Olav Nygaard wrote:

>> Any ideas?

> Yep, I just use ntp (see BLFS).  My hardware clock seems to gain even 


Tried this and went for the first option mentioned in the BLFS-book:

   Option one is to run ntpd continuously and allow it to
   synchronize the time in a gradual manner.

That is, I installed /etc/rc.d/init.d/ntp. When I run it, I get this:

   >ps aux | grep ntpd     < nothing reported >
   >/etc/rc.d/init.d/ntp status
   /usr/sbin/ntpd is not running.
   >/etc/rc.d/init.d/ntp start
   Starting ntpd...
   ntpd: time slew -34.332020s
   Unable to continue: /usr/sbin/ntpd is running         [ WARN ]

When looking into the script, I see that there are two lines,

   ntpd -gqx
   loadproc /usr/sbin/ntpd

On my machine, it seems that the second command causes ntpd to
fail to start because it thinks it is already running. Should there
be inserted a small pause in between these two commands?
[Correction, I think it is the 'loadproc' that wrongly thinks ntpd is
running.] Reading the comment at the top of 'loadproc', it says
"will be removed after BLFS 6.0" (a check for PIDFILE I guess).
Maybe this is not a good idea, or maybe I have gotten a mixture of
some pre-6.0 and post-6.0 BLFS_stuff infecting my system?

J.O.



More information about the lfs-dev mailing list