GCC-4.0.1

Randy McMurchy LFS-User at mcmurchy.com
Fri Aug 19 22:55:21 PDT 2005


Hi all,

I would like to propose a consideration for LFS to move towards the
GCC-4 branch as the default LFS build. There are issues, but none that
are really show-stoppers.

I have built over 150 packages using the GCC-4 branch of LFS without
anything that I can see is "buggy". Except of course, the Shadow/PAM
su thing if you mistype your password.

BLFS is probably ready to migrate, as patches exist for the major
packages that require help with GCC-4, and for those that don't we
will get to them in due time.

This idea is just a consideration, and unless an LFS-6.2 is going to
be released soon (don't see how until a GCC-3.4.5 version is released
and tested), it may be worthy of implementation.

Further discussion is welcome.

-- 
Randy

rmlscsi: [GNU ld version 2.15.94.0.2 20041220] [gcc (GCC) 3.4.3]
[GNU C Library stable release version 2.3.4] [Linux 2.6.10 i686]
00:48:01 up 140 days, 21 min, 3 users, load average: 0.47, 0.23, 0.21



More information about the lfs-dev mailing list