Book rendering

Luca liliana.perossa at fastwebnet.it
Mon Dec 11 03:46:27 PST 2006


M.Canales.es wrote:
> Yes, it's broken. In the first xsltproc command the --xinclude option is 
> missing. And when generating the blfs-book.tex file the parsing fails with:
>
> compilation error: 
> file /usr/share/docbook/db2latex-xsl-0.8pre1/xsl/qandaset.mod.xsl line 366 
> element template
> xsl:template: error duplicate name 'question.answer.label'
>
> That is due a bug in db2latex that could be avoided by commenting out the line 
>
> <xsl:include href="qandaset.mod.xsl"/>
>
> in db2latex-xsl-0.8pre1/xsl/docbook.xsl.
>
> The parsing will still output several errors but blfs-book.tex is created. I 
> don't know if that tex file can be compiled due that that don't have 
> installed TeX or LaTeX right now, but the last time I tried, more than 2 
> years ago, the PDF generated was bugy and very ugly.
>
>
>   
Thanks for the answer Manuel.

Now it's clearer; I'm not 100% sure but when I passed make tex maybe the
errors were others and not the one you mentioned, they should be
something like DB2Latex: Need to process XPath match book/xi:include but
as already said not sure.
I tried to process other tex files and it seems to work; dunno.
Debian uses db2lated with a patch of its own but don't know if it solves
the problem.

Luca



More information about the lfs-dev mailing list