linux-2.6.17 and openat

Robert Connolly robert at linuxfromscratch.org
Tue Jun 20 18:42:42 PDT 2006


Hi. when I use --enable-kernel=2.6.17 with glibc-2.4 or glibc-cvs, using 
linux-2.6.17-rc6-mm2 and linux-2.6.17.1, raw headers and running kernel, I 
get:
./sysdeps/unix/sysv/linux/openat.c:156: error: 'va_start' used in function 
with fixed args

With --enable-kernel=2.6.16 there's no problem. I read 2.6.17 patched 
openat(). Anyone know about this?

robert



More information about the lfs-dev mailing list