Ch.3.2 outdated note(?)

Matthew Burgess matthew at
Fri Nov 3 00:07:47 PST 2006

Rainer Wirtz wrote:
> Hi
> In LFS-SVN-20061029, Chapter 3.2 there's a note reading:
> The Linux kernel is updated relatively often, many times due to 
> discoveries of security vulnerabilities. The latest available 2.6.17.x 
> kernel version should be used, unless the errata page says otherwise. 
> Do not use version 2.6.18 or later kernels due to potential 
> incompatibilites with the bootscripts.
> This is right below the download link to kernel
> I assume the note is outdated and should be changed or removed, right?

Thanks.  We should be using the version numbers from packages.ent, 
rather than a hard-coded value.  Unfortunately they were structured in 
such a way as to make using them in this context awkward.  I've rejigged 
things a bit and committed a fix in r7852.  I thought it was safe to 
remove the warnings about incompatibilities with the bootscripts as I 
think this was really to do with the udev related issues with 2.6.18. 
If anyone thinks the warning is still relevant, give me a shout and I'll 
put it back in.



More information about the lfs-dev mailing list