lfs-bootscripts-6.2

Alex Merry alexander.merry at ccc.ox.ac.uk
Tue Oct 31 15:22:38 PST 2006


On Tuesday 31 October 2006 17:59, thorsten wrote:
> And tried to stop them with
> killproc -p /var/run/openvpn-1.pid openvpn and
> killproc -p /var/run/openvpn-2.pid openvpn respectively.
>
> When both instances are up and I tried to stop one of both, the right
> openvpn process gets killed and the pidfile removed but the script
> reports a [failed] due to the fact that pidofproc one time gets
> called without the -p option. I tried to correct it with the appended
> patch. I also tried to correct a message generated by kill "no such
> process", which should go to /dev/null I guess.

This is the same problem Alexander mentioned the other day, I believe.

Alex :-)

-- 
Pippin
Computer Monkey to the Pelican
www.oxrev.org.uk, www.corpusjcr.org, www.rev.org.uk
0870 120 0870, ext 26669
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20061031/80f76c45/attachment.sig>


More information about the lfs-dev mailing list