Linux Test Project

Bruce Dubbs bruce.dubbs at gmail.com
Tue Mar 20 17:31:31 PDT 2007


Just a note to say I was trying out the LTP today on my 6.2 test system.

http://ltp.sourceforge.net/

I ran the tests and got four failures:

mincore01                      FAIL       1
gf15                           FAIL       1
gf17                           FAIL       1
gf18                           FAIL       1

gf stands for growfiles and the reason they failed is that I ran out of
disk space (I had 1.3G free).  When I created a new 10G partition for
them, the gf tests passed.

The mincore01 gives:

$ sudo ./mincore01
mincore01    1  PASS  :  expected failure: errno = 22 (Invalid argument)
mincore01    2  PASS  :  expected failure: errno = 14 (Bad address)
mincore01    3  FAIL  :  call succeeded unexpectedly
mincore01    4  PASS  :  expected failure: errno = 12 (Cannot allocate
memory)

Details:
test3:   Invoke mincore() when the vector points to an invalid address.

This may be a bug in the test suite.  The address they specify is NULL,
but the length is zero.

In other words, it looks like LFS is a pretty strong system (If you
didn't already know that).

  -- Bruce



More information about the lfs-dev mailing list