LTP failure

Bruce Dubbs bruce.dubbs at gmail.com
Wed Mar 21 08:31:29 PDT 2007


Bryan Kadzban wrote:
> Bruce Dubbs wrote:
>> I've been trying to figure out why the attached file fails on my LFS 
>> systems.  It does not fail on FC or RHEL kernels.
> 
> Neither mincore01 nor mincore02 fail on my (C)LFS system either.  But
> it's not exactly LFS, so it's probably not a great test.
> 
> It's a multilib x86-64 setup (with a 64-bit kernel, of course).  Kernel
> version is 2.6.19.1 (which I need to upgrade one of these days).  I
> wonder if there was maybe some different behavior added in the kernel
> since 2.6.16.27?
> 
> Also, when I run your test program (after changing the (unsigned int)
> cast to an (unsigned long int) cast and changing the printf format
> specifier to match, since pointers on my setup are 64 bits wide), I
> don't get a failure whether I pass an argument to min or not.
> 
> But again, this system is probably too different from standard LFS to be
> a great test.  The 64-bit stuff especially seems like it'd affect this
> test, at least a bit.

Thanks Bryan.  It's still a mystery to me.  I tried a 2.6.20.3 kernel
last night and it still failed for me.  Experimenting showed that the
printf needs to be before the mmap function to make a difference, so I
am hypothesizing that the issue is in mmap.

  -- Bruce





More information about the lfs-dev mailing list