LTP failure

Bruce Dubbs bruce.dubbs at gmail.com
Thu Mar 22 08:40:16 PDT 2007


Bryan Kadzban wrote:
> Bryan Kadzban wrote:
>> On Wed, Mar 21, 2007 at 10:31:29AM -0500, Bruce Dubbs wrote:
>>> Thanks Bryan.  It's still a mystery to me.  I tried a 2.6.20.3 
>>> kernel last night and it still failed for me.
>> Well, I can try installing 2.6.20.3 to see if it also fails for me; 
>> perhaps 2.6.19.1 is an oddball?  I know it has some other issues, so 
>> I should upgrade it anyway.
> 
> 2.6.20.3 also passes the test for me (fails the call).  I suspect it's
> because it's 64-bit though.  mmap seems likely to be affected by the
> architecture (more than some other syscalls, anyway).  mincore does too.
> 
> If I still have my 32-bit partition laying around, I can try to upgrade
> its kernel and see whether 2.6.20.3 fails for me in 32-bit mode.  But
> it'll take a while.

Thanks Bryan.  I've gotten a couple of reports of failures in 32 bit
systems but all reports about 64 bit systems pass.  I've personally
tried 2.4.x, 2.6.12.5, and 2.6.20.3 kernels and all have the same
incorrect behavior.

  -- Bruce





More information about the lfs-dev mailing list