Texinfo-4.11 and binutils

Alexander Kozlov ako3108-ml at yahoo.se
Sun Sep 16 09:05:14 PDT 2007


Hello!

(My first post here so please excuse me if it is OT or
misconfigured)

Binutils 2.17/2.18 configure script requires texinfo
4.4 or higher to be installed. The version checking
code works for versions 4.4 through 4.9 and breaks
with texinfo 4.11:

    if ${MAKEINFO} --version \
       | egrep
'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null
2>&1; then
      :
    else
      MAKEINFO="$MISSING makeinfo"
    fi

To allow two-digit 4.xx subversions, one could change
the search pattern in binutils-*/configure to
something like

egrep
'texinfo[^0-9]*([1-3][0-9]|4\.([4-9]|[1-9][0-9])|[5-9])'

or disable the check completely.

Regards,
Alexander Kozlov.



      ___________________________________________________
Sök efter kärleken!
Hitta din tvillingsjäl på Yahoo! Dejting: http://se.meetic.yahoo.net



More information about the lfs-dev mailing list