Problems w/ libpng 1.2.18 w/ links

Ag. D. Hatzimanikas a.hatzim at gmail.com
Tue Feb 26 12:15:07 PST 2008


On Fri, Feb 22, at 11:53 Nathan Coulson wrote:
> On Fri, Feb 22, 2008 at 5:15 PM, DJ Lucas <dj at linuxfromscratch.org> wrote:
> > Nathan Coulson wrote:
> >  > I was playing w/ links in the linux framebuffer, and I came across this error
> >  >
> >  > Error when loading compiled-in font: png_do_rgb_to_gray found nongray pixel.
> >  > libpng error: png_do_rgb_to_gray found nongray pixel.
> >  >
> >  > a bit of googling pulled up this link
> >  >
> >  > http://bugs.gentoo.org/show_bug.cgi?id=181318
> >  >
> >  > There is a patch, located at
> >  > http://bugs.gentoo.org/attachment.cgi?id=124398&action=view (found
> >  > within the bugreport).
> >  >
> >  > I also noticed that  there is a libpng 1.2.25 on the download site.
> >  >
> >
> >  Thanks Nathan.  I assume the patch fixed the problem for you.  I'll
> >  verify that it's in 1.2.25 and get that in the book.  I'm using 1.2.24
> >  without issue (well, AFAIK without issue).
> >
> >  -- DJ Lucas
> 
> well, installing 1.2.25 fixed it for me...
> 

Yes, same here.

I updated links to 2.1pre33.

Karel, I would appreciated it if you could have a look at the
instructions [1] and provide feedback if any. Or any other configuration
item or whatever you think it's good to have it in the book.
I enabled graphics support by default.
I also checked the caution note by Alexander and I still see the same
behavior that he describes. 

1. http://wiki.linuxfromscratch.org/blfs/changeset?old_path=trunk&old=7197&new_path=trunk&new=7197

Dj, we have to either update libpng to 1.2.25 or patch 2.1.18.

-- 
http://wiki.linuxfromscratch.org/blfs/wiki/Hacking



More information about the lfs-dev mailing list