Shadows 'groupmems' program segfaults

Randy McMurchy randy at linuxfromscratch.org
Sun Oct 12 12:50:32 PDT 2008


Robert Connolly wrote:

> As root, I tried every 'groupmems' option, and they all work. I'm using 
> shadow-4.1.2.1, glibc-2.8-20080908, binutils-2.18.50.0.9, and 
> gcc-4.2.5-20080903.

I cannot reproduce the segfault. Not sure why. Strange.

One thing that needs to be reported upstream, however.
The groupmems program only updates /etc/group and doesn't
update /etc/gshadow. Seems the program should update both
for consistency sake.

-- 
Randy



More information about the lfs-dev mailing list