Minimum Host Prerequisites

Gilles Espinasse g.esp at free.fr
Mon Oct 20 10:24:50 PDT 2008


Selon Ken Moffat <ken at linuxfromscratch.org>:
...
>
>  In an *ideal* world, I still think that building the kernel version
> used in LFS on the host is the way to go.  Doesn't fit every usage,
> but it has to be a lot better than attempting to support people
> building from some antique version of 2.6.

LFS dev has on glibc --enable-kernel=2.6.0
FC9 has set --enable-kernel=2.6.9
Debian lenny has set --enable-kernel=2.6.18
Greg has the same 2.6.18 setting on glibc chroot compilation (but nothing on
first compilation).

It does not look clear to me if the reason for debian to set 2.6.18 are valid
"...Currently, MIN_KERNEL_SUPPORTED is set to 2.6.9 and (as you know)
leaves out some newer features.
..."

My understanding was that more compatibility workaround were enabled with a
lower --enable-kernel, not that it disable some new features. I may have been
partially wrong, reading glibc manual:
"The higher the version number is, the less compatibility code is added, and the
faster the code gets."

On IPCop, we had choosen --enable-kernel=2.6.5 because of a reference I can no
more found explaining using 2.6.0 may trigger some bugs.

Should you not consider to increase --enable-kernel, at least to 2.6.9?

Gilles

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499689
http://cvs.fedoraproject.org/viewvc/rpms/glibc/F-9/glibc.spec?revision=1.364&view=markup




More information about the lfs-dev mailing list