Patch names (security, fixes)
bruce.dubbs at gmail.com
Thu Oct 23 19:11:44 PDT 2008
Robert Connolly wrote:
> How about "upstream_fixes" for bug patch(es) which are in upstream,
> and "community_fixes" for other bug patch(es) which are not in upstream? and
> stop using "security" in patch names, because bugs are bugs.
> For our purpose, we can use a plural "fixes" even if the patch only fixes one
> issue, because it may be added on to later. Just to keep the naming coherent.
> Other patches would typically be feature additions, and can be named according
> to that.
> If one patch depends on another, upstream comes first, then community, then
I like that. We don't need to go and rename everything right now, but we can do
that for any new patches.
More information about the lfs-dev