udev 1.42 : vol_id missing

William Immendorf will.immendorf at gmail.com
Sat Jun 20 07:10:51 PDT 2009


On Sat, Jun 20, 2009 at 3:54 AM, Tobias Gasser<lfs at ebp-gasser.ch> wrote:
> with e2fsprogs 1.41.6, util-linux-ng 2.15.1 and udev 1.42 it looks like
> everything behaves as expected. just use the svn-20090611 with the
> updated e2fsprog and util-linux-ng including "--with-fsprobe=builtin"
> for util-linux-ng
I see a problem here. As util-linux-ng compiles just after udev,
udev-142 will probably want the util-linux version of libblkd, but,
either:

 * Udev's configure fails, saying that it needs the util-linux version
of libblkd, or
 * It will link aganst the libblkd in /tools, and we don't want that to happen.

The solution is to compile Util-linux-ng in front of Udev.

William



More information about the lfs-dev mailing list