glibc-2.10.1 make check fails

Bryan Kadzban bryan at kadzban.is-a-geek.net
Sun May 24 22:51:22 PDT 2009


Bruce Dubbs wrote:
> --enable-kernel=VERSION compile for compatibility with kernel not older than
>    VERSION

Yes: abort any program at startup if the current kernel version is less
than VERSION, and also remove any workarounds included in the glibc
sources for kernels older than VERSION (if any).

> but I found http://www.mail-archive.com/arch-dev-public@archlinux.org/msg08016.html
> 
> which says:  The minimum kernel version required for glibc was bumped from 
> 2.6.16 to 2.6.18

That's an Arch decision (made by their maintainer), not something that
applies to glibc itself.  :-)  See:

http://repos.archlinux.org/viewvc.cgi/glibc/repos/core-x86_64/PKGBUILD?r1=36985&r2=39100

for the actual change in their PKGBUILD script.  (The section labeled
"line 62".)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20090524/9726a791/attachment.sig>


More information about the lfs-dev mailing list