glibc-2.10.1 make check fails

Gilles Espinasse g.esp at free.fr
Tue May 26 09:47:36 PDT 2009


----- Original Message ----- 
From: "Bruce Dubbs" <bruce.dubbs at gmail.com>
To: "LFS Developers Mailinglist" <lfs-dev at linuxfromscratch.org>
Sent: Tuesday, May 26, 2009 6:32 PM
Subject: Re: glibc-2.10.1 make check fails


...
>
> Using 2.6.18 appears to potentially affect binaries built against kernels
older
> than that and run on a LFS-6.5 or later system. I don't see where that
would be
> an issue.
>
>    -- Bruce

No.
The issue is that if you have a kernel running on the building machine older
than the version defined in --enable-kernel, building glibc will fail with
'kernel too old message'.
So --enable-kernel primary limit to wich kernel version is needed to build
LFS.
So to be clear, if someone want to build LFS from RHEL-5 or debian etch,
2.6.18 is fine. But on any older kernel, glibc compilation will fail.

At least that was I have seen before the switch to cross-compilation.

    Gilles




More information about the lfs-dev mailing list