glibc-2.10.1 make check fails

Bruce Dubbs bruce.dubbs at gmail.com
Tue May 26 10:03:05 PDT 2009


Gilles Espinasse wrote:
> ----- Original Message ----- 
> From: "Bruce Dubbs" <bruce.dubbs at gmail.com> To: 

>> Using 2.6.18 appears to potentially affect binaries built against kernels 
>> older than that and run on a LFS-6.5 or later system. I don't see where
>> that would be an issue.

> No. The issue is that if you have a kernel running on the building machine 
> older than the version defined in --enable-kernel, building glibc will fail 
> with 'kernel too old message'. So --enable-kernel primary limit to wich 
> kernel version is needed to build LFS. So to be clear, if someone want to 
> build LFS from RHEL-5 or debian etch, 2.6.18 is fine. But on any older 
> kernel, glibc compilation will fail.
> 
> At least that was I have seen before the switch to cross-compilation.

 From what I see, the consequence is what you describe, but the reason for the 
behavior is what I wrote.

You've triggered a thought: using 2.6.18 will require a change to the Preface 
section "Host System Requirements", although it would be relatively easy for 
someone to back off to an earlier kernel just by specifying a different kernel 
in the configure line of glibc.

   -- Bruce



More information about the lfs-dev mailing list