glibc-2.10.1 make check fails

Trent Shea trent.shea at gmail.com
Wed May 27 11:58:06 PDT 2009


On Wednesday 27 May 2009 12:13:09 Bruce Dubbs wrote:

> That's interesting.  I don't see those errors, but perhaps that's because
> I'm building on an LFS-6.4 system with a 2.6.27.4 kernel.
The errors were only triggered by having the 'bad' kernel version running.

> > Another note regarding the 2.6.29.4 kernel headers. When running make
> > headers_check there are many 'leaks' and 'extern's make no sense in
> > userspace' messages, the 2.6.28.10 kernel does not produce these
> > messages. Maybe an explanation regarding these messages could be
> > considered?
>
> I haven't seen these either.  Are you building 6.5 on a 6.5 system?
I've had these kind of messages for some time. They can also be viewed on 
ubuntu by unpacking the kernel source and running make headers_check on 
versions later than 2.6.28.10. It's possible these messages were added to help 
kernel developers, but I haven't had a chance to research this yet.


Trent.



More information about the lfs-dev mailing list