grub-0.97 test failure

Bruce Dubbs bruce.dubbs at gmail.com
Thu May 28 15:02:00 PDT 2009


Trent Shea wrote:
> Has anyone experienced this error when running make check on grub-0.97? The 
> test fails when building trunk Revision: 8935 (in chroot, and if I boot into 
> the 6.5 system and build.)

> I eventually got it to pass the test by using the following CFLAGS:
> export CFLAGS="-march=i486 -mtune=native -Os"
> I copied the first flags from the glibc section and had to add '-Os' to get 
> the size down. I'm really out of my element here, so any review on this 
> approach would be appreciated.
> 
> I referenced http://en.gentoo-wiki.com/wiki/CFLAGS for the '-Os' flag.

Interesting.  ALFS doesn't seem to run the grub package at all which is in 
Chapter 8.

When I run it manually, I get the same error.

ffs_stage1_5 is too big (8008 > 7168).

Using make CFLAGS="-march=i486 -mtune=native -Os" does indeed make it pass.

There is a --disable-ffs configure switch, but it makes ffs_stage1_5 anyway and 
the check fails.

The ffs is only used if you are booting from the Berkeley Fast File System, also 
known as the BSD Fast File System, so it's not really a problem.


I'll go ahead and update the book with the CFLAGS.

Thanks for the report.

   -- Bruce



More information about the lfs-dev mailing list