[lfs-6.7-rc1] Cannot mount ext4 partitions

Estevao B. K. icmp.request.lists at gmail.com
Sat Sep 18 10:37:27 PDT 2010


Hello! So, is this normal I'm not being able to mount an ext4 partiton, 
provided I have enabled support for it at the kernel? Please check 
below. Although I have tried to modprobe, I have the support as built-in 
on the kernel. I have not enabled debugging support neither extended 
attributes. And I am able to mount from other distros, so the problem is 
with my LFS build, IF it was supposed to work.

Thanks in advance for any help!

# mkdir /sdb6
# mount /dev/sdb6 /sdb6
mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
        missing codepage or helper program, or other error
        In some cases useful info is found in syslog - try
        dmesg | tail  or so

# mount -t ext4 /dev/sdb6 /sdb6
mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
        missing codepage or helper program, or other error
        In some cases useful info is found in syslog - try
        dmesg | tail  or so

# modprobe ext4
# mount -t ext4 /dev/sdb6 /sdb6
mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
        missing codepage or helper program, or other error
        In some cases useful info is found in syslog - try
        dmesg | tail  or so

# blkid /dev/sdb6
/dev/sdb6: LABEL="FEDORA" UUID="0e895994-5eb7-4e93-a194-c8d0dc8a39c5" 
TYPE="ext4"
# mount /dev/disk/by-label/FEDORA /sdb6/
mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
        missing codepage or helper program, or other error
        In some cases useful info is found in syslog - try
        dmesg | tail  or so

#



More information about the lfs-dev mailing list