gcc-4.6.0

Matthew Burgess matthew at linuxfromscratch.org
Sun Mar 27 12:01:26 PDT 2011


On Sun, 27 Mar 2011 11:36:36 -0600, Matthew Burgess <matthew at linuxfromscratch.org> wrote:
> On Sun, 27 Mar 2011 18:18:18 +0100, Andrew Benton <b3nton at gmail.com> wrote:
>> Hello World,
>> I see that gcc-4.6.0 is out. I tried to use it but the build fails at
>> the first pass in libquadmath with an error about GCC_NO_EXECUTABLES.
>> So I added --disable-libquadmath to the configure line but it didn't
>> help. It still fails in libiberty like so:
> 
> Hmm, that's odd. I saw the same error in libquadmath and passing
> --disable-libquadmath was enough to get gcc-4.6.0 to build here.  Note
> I only needed to add it to GCC-Pass1. The other 2 passes are fine.

Just to be clear here, the only change I made to GCC's instructions was for
the invocation of configure in GCC pass 1, which in full is:

../gcc-4.6.0/configure \
  --target=$LFS_TGT --prefix=/tools \
  --disable-nls --disable-shared --disable-multilib \
  --disable-decimal-float --disable-threads \
  --disable-libmudflap --disable-libssp \
  --disable-libgomp --disable-libquadmath --enable-languages=c \
  --without-ppl --without-cloog

I also had to add change the 'make check' for binutils to 'make -j check || exit 0'
so that jhalfs would carry on after the I got hit by 4 unexpected failures in its
testsuite.  I'll investigate those once this build completes.

This is all being done on an i686, so I wonder whether your results, Andy, may be
due to a 64-bit arch?  That said, the error you're seeing seems a general
configure script bug rather than anything arch-specific.

Regards,

Matt.




More information about the lfs-dev mailing list