[lfs-dev] Booting with systemd

Bruce Dubbs bruce.dubbs at gmail.com
Sun May 4 19:04:13 PDT 2014


William Harrington wrote:
>
> On May 4, 2014, at 3:38 PM, Bruce Dubbs wrote:
>
>> Seems benign enough to me, but I keep getting timeouts trying to mount
>> /boot, /home, /usr/src, and swap.
>
> It could possibly be related to
> http://www.freedesktop.org/software/systemd/man/systemd-gpt-auto-generator.html
>
> Have you had a look through that along with
> systemd-efi-boot-generator(8) and the Generator Specification at the
> above link?
>
> I haven't used gpt, but maybe something there will help.


systemd-gpt-auto-generator and systemd-efi-boot-generator are binaries, 
but I can try to remove them.

"Note that this generator has no effect on non-GPT systems, on systems 
where the units are explicitly configured (for example, listed in 
fstab(5)), or where the mount points are non-empty."

If it works as documented, it shouldn't do anything because all the 
mount points are listed in fstab.

Note too that I blew away Windows completely, so I don't have an EFI 
System Partition, but I do have an EFI type bios.

I tried removing the files, but that didn't help.

This type of problem reinforces my dislike of systemd.  If it were a 
simple boot script, I could just comment out the offending line and get 
up and debug that function.  Here, the logic if buried deep in compiled 
code or multiple configuration files with opaque inter-dependencies.

I'm really trying to make this work, but it keeps throwing problems up. 
  I tried Fedora 20 (with LXDE) and it didn't seem to work either.  It 
hangs with no apparent error messages.

   -- Bruce


More information about the lfs-dev mailing list