[lfs-dev] Cannot run init-net-rules.sh

Ken Moffat zarniwhoop at ntlworld.com
Sat May 17 15:21:12 PDT 2014


On Sat, May 17, 2014 at 10:29:42PM +0200, ALZ (phyglos.org) wrote:
> In section 7.4.1.2, I cannot execute init-net-rules.sh
> 
> When is this script installed in SVN? 
> In LFS 7.5 udev-lfs scripts are installed with udev-208.
> 
> ALZ.

 Good question.  The only reference is in the commented-out systemd
page.  The udev-lfs-20140408 tarball is listed in packages, but I
have no idea what Bruce's intention was : He put 55-lfs.rules onto
the eudev page, but I don't know if he intended that the other rules
should be dropped.

 If all you want to do is to get going, and to ensure that a single
wired ethernet port is called eth0, the quickest way (worked with
eudev up to and including 1.5.3, I haven't tried this with 1.6)
would be:

 echo "# dummy, so that network is once again on eth0" \
   >/etc/udev/rules.d/80-net-name-slot.rules

 Or you could untar the lfs rules and run execute init-net-rules.sh.

 I guess my own build will have to wait until Bruce lets us in on
this secret.

ĸen
-- 
das eine Mal als Tragödie, dieses Mal als Farce


More information about the lfs-dev mailing list