[lfs-dev] kernel build failure on current lfs-dev

Ken Moffat zarniwhoop at ntlworld.com
Wed May 21 07:51:42 PDT 2014


 (Third attempt - the first time I attached my .config, but that
made it too big for this list.  The config is now at
http://www.linuxfromscratch.org/~ken/tmp/config-3.14.4  And then I
mistyped the to: address)

 This is on LFS-svn-20140514 (r10564) with the udev-lfs
reinstatement from r10567.  I'm on x86_64, trying to build 3.4.14
using the config from 3.4.14 which the host (LFS-7.5) is running.

  GEN     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  CC      scripts/mod/empty.o
as: symbol lookup error: /usr/lib/libbfd-2.24.so: undefined symbol:
ons
scripts/Makefile.build:308: recipe for target 'scripts/mod/empty.o'
failed
make[2]: *** [scripts/mod/empty.o] Error 2
scripts/Makefile.build:455: recipe for target 'scripts/mod' failed
make[1]: *** [scripts/mod] Error 2
Makefile:527: recipe for target 'scripts' failed
make: *** [scripts] Error 2

 Google produced a lot of references, but all of those at the head
of its list are for random values of "undefined symbol:" in random
packages.  It seems to me that this is either caused by

 binutils-2.24-load_gcc_lto_plugin_by_default-1.patch

 and the associated changes to make that effective, or by

 gcc-4.9.0-upstream_fixes-1.patch

 Curiously, my build on my Sandy Bridge (where I went ahead with the
"simple" fix for eth0 in Bruce's absence, and which also omits acl
as "unneeded") uses the same versions, plus its own kernel config,
has booted and successfully built my normal desktop (although most
of that has not been tested to see if it works).

 So for me, this version of the book is dead in the water.  This may
well be a "kernel does not like this modified version of gcc-4.9.0"
problem, or "kernel does not like LTO" (I thought I'd seen a few of
those mentioned on lkml in recent weeks, although a quick look
suggests lto is not the default and in fact it is kernel devs who
didn't like the attempt to enable it) but I have no idea where to
look.

 I've just tried "make mrproper", followed by removing the
/usr/lib/bfd-plugins/liblto_plugin.so symlink (to see if that was
the cause), but when I then tried

 zcat /proc/config.gz >.config
 make oldconfig

 I got:
  HOSTCC  scripts/basic/fixdep
as: symbol lookup error: /usr/lib/libbfd-2.24.so: undefined symbol:
ons
scripts/Makefile.host:118: recipe for target 'scripts/basic/fixdep'
failed
make[1]: *** [scripts/basic/fixdep] Error 1
Makefile:428: recipe for target 'scripts_basic' failed
make: *** [scripts_basic] Error 2

 On the first attempt, the compiles (with -j4) scrolled out of my
rxvt-unicode term's buffer so I'm fairly sure that I didn't get this
error at the start on that occasion.

 Whatever, this build is not going anywhere.  Bereft of life, it has
joined the choir invisibule.  This is an ex LFS build.

 [ /me went to bed and slept ]

 Update: since my previous attempts to send this, I've tried that
config on my intel (same build, except for the absence of 'acl' and
a difference in how I force the network to be 'eth0').  On that, it
works.  I'm becoming increasingly baffled.  Will go back to chroot
on the problem machine, reinstate the lto symlink, and have another
attempt.

ĸen
-- 
das eine Mal als Tragödie, dieses Mal als Farce


More information about the lfs-dev mailing list