[lfs-dev] gcc --with-glibc-version

Bruce Dubbs bruce.dubbs at gmail.com
Mon Mar 30 09:48:44 PDT 2015


There is a message on -support, 
http://lists.linuxfromscratch.org/pipermail/lfs-support/2015-March/048605.html, 
that suggests dropping the sed to gcc/configure in Chapter 5 gcc-pass1 and using 
--with-glibc-version=m.n instead.

I've taken a look and it seems reasonable.

I ran a test and used --with-glibc-version=2.11 and the stack check parameter 
was properly picked up.  The reason for 2.11 is that buried in the configure 
code is an option (#define HAVE_GAS_GNU_UNIQUE_OBJECT 1) that is set if 2.11 or 
later is specified/detected.

I'm not sure if this change would require the host system to have glibc 2.11 or 
later, but it probably wouldn't hurt.  That glibc version was released Nov 2009. 
  The version we require in the host system requirements now is glibc-2.5.1 and 
the current version is glibc-2.21.

This change does not seem to be risky.  The only packages that really could be 
affected are Chapter 5's glibc, libstdc++, binutils-pass2, and gcc-pass2.  Of 
course everything gets rebuilt in Chapter 6 anyway.

We have a lot of time until the next stable LFS release for testing.  Should I 
go ahead and make the change?

   -- Bruce


More information about the lfs-dev mailing list