[lfs-dev] gcc --with-glibc-version

Bruce Dubbs bruce.dubbs at gmail.com
Mon Mar 30 19:18:08 PDT 2015


Bryan Kadzban wrote:
> Bruce Dubbs wrote:
>> I ran a test and used --with-glibc-version=2.11 and the stack check
>> parameter was properly picked up.  The reason for 2.11 is that buried in
>> the configure code is an option (#define HAVE_GAS_GNU_UNIQUE_OBJECT 1) that
>> is set if 2.11 or later is specified/detected.
>>
>> I'm not sure if this change would require the host system to have glibc
>> 2.11 or later, but it probably wouldn't hurt.  That glibc version was
>> released Nov 2009.
>
> ...My main system is running glibc-2.10.1.  My firewall is running glibc-2.3.2
> -- although in that case, it doesn't matter as I'll cross compile from the
> main system instead of building a new LFS on the machine.  (It's a P3, single
> core.  It'll take forever to build on the machine.)
>
> I'd really rather avoid making changes that require libcs newer than 2.10.1 on
> the host, as it would seem to mean that I'm out of luck on ever getting back
> onto a current build.  (As it would take too much to build an e.g. LFS 7ish
> setup, followed by whatever "current" is at the time.)

I know what you mean.  I Use a vintage 2005 686 as my workstation.  (It has 
really good graphics and I did a complete upgrade in 2012).

In your case though, you would only need to change to --with-glibc-version=2.10, 
but I am guessing it would work with 2.11 anyway.

The good news is that the change is very early in the build and any issues would 
happen early in the process.

   -- Bruce




More information about the lfs-dev mailing list