[lfs-dev] faad and faac

Bruce Dubbs bruce.dubbs at gmail.com
Mon Oct 16 21:05:37 PDT 2017


Cheyenne McNutt wrote:
>
>
> On Mon, Oct 16, 2017 at 9:59 PM, Bruce Dubbs <bruce.dubbs at gmail.com
> <mailto:bruce.dubbs at gmail.com>> wrote:
>
>     I am having a problem updating the subject packages,
>
>     faac is now version 1.29.7.8 and 1.29.8 has been released.
>     faad is now version 2.8.5 and 2.8.6 has been released.
>
>     Both build without issue.
>
>     The testing procedure uses both packages.
>
>     For faac, from the build directory:
>
>     ./frontend/faac -o Front_Left.mp4 /usr/share/sounds/alsa/Front_Left.wav
>     faad Front_Left.mp4
>     aplay Front_Left.wav
>
>     for faad, from that package's build directory:
>
>     ./frontend/faad -o sample.wav ../sample.aac
>     aplay sample.wav
>
>     The testing in the book for faad works fine. The aplay command in faac
>     appears to work, but does not output any audio.  The existing package
>     versions work fine for both packages.
>
>     I tried cvlc to play Front_Left.mp4, and it plays fine.  Actually cvlc
>     plays Front_Left.wav but truncates the audio to "Front" only. aplay
>     gives no audio at all.
>
>     These are very easy packages to build as they have no dependencies
>     (other than alsa-utils or vlc or some other audio package for
>     testing).  I'd appreciate it if someone can test these packages to see
>     if the the results are the same.

> I'd be willing to give it a shot. I'll have Douglas guide me through it.
> It'll likely take a day or two.

That may be a reasonable introduction.  Looking forward to your results.

    -- Bruce




More information about the lfs-dev mailing list