[lfs-dev] BLFS no longer provide Qt4

Bruce Dubbs bruce.dubbs at gmail.com
Tue Mar 20 09:22:05 PDT 2018


On 03/20/2018 09:41 AM, Xi Ruoyao wrote:
> In "LFS and Standards" (prologue/standards.xml) it lists Qt4 as a
> LSB package provided by BLFS.  But now BLFS only supports Qt5.
> 
> So Qt4 seems to be a package not supplied by LFS or BLFS needed to
> satisfy LSB now :(.

The LSB was published in 2015.  There was an LSB bug filed in 2013 to 
address this: https://lsbbugs.linuxfoundation.org/show_bug.cgi?id=3813

It is still open.  Standards development does not keep pace with 
software development.  There probably will be a Qt6 released within a year.

That said, I will update the page.

   -- Bruce



More information about the lfs-dev mailing list