[lfs-dev] systemd-238

William Harrington kb0iic at berzerkula.org
Sat Mar 24 07:08:31 PDT 2018


On Fri, 23 Mar 2018 17:56:39 -0500
Jonathan Cottrill <linuxfromscratch at jonathancottrill.net> wrote:

> On Friday, March 23, 2018 5:33:21 PM CDT Alain Toussaint wrote:
> > 
> > > This error only happens in chroot.  On a full-up 8.2 system, the same 
> > > commands above do not produce an error.
> > > 
> > > Help appreciated.
> > 
> > 
> > I'm  on it, I'll start a jhalfs automated build soon and made the necessary 
> changes to packages.ent
> > in LFS-svn sources to use systemd 238 instead of 237.
> > 
> > Base Linux in front of the chroot is debian 9.4 at the moment (I've been 
> itchy to replace it with
> > LFS+BLFS for a long time already).
> > 
> > Alain
> 
> Looks like there's a bit of a mess with the headers; there's an issue open. A 
> commit was made yesterday to "make it more robust," but in the meantime, 
> there's a patch available in the issue that is reported to work:
> 
> https://github.com/systemd/systemd/issues/8507

I just had an issue where I was going to upgrade from 236 to 237 and I had upgraded libgpg-error from 1.27 to 1.28  I had to go back to 1.27 for 236 and 237 to build. I'm going to test 238 and see what happens.

with libgpg-error 1.27 both Systemd 236, 237 and 238 build fine. It's libgpg-error 1.28 when the issue surfaces.

https://hastebin.com/irotixezin.cs

Sincerely,
 
Berzerkula <kb0iic at berzerkula.org>


More information about the lfs-dev mailing list