Cannot make fileutils

Richard Brust richard at
Sun Mar 3 10:37:07 PST 2002

Gerard -

Thanks for the tip.  I increased the swap, re-ran make, and it failed.  Did 
a "make clean", ran "make" again, and it worked fine.  The ram problem was 
probably it.  However, I then moved on to the gcc package, and after 12 or 
so tries, (both the 2.95 that came with LFS, and the new 3.0.4 I 
downloaded), I have come to the conclusion that there must be something 
wrong with my system.  The gcc fails every time, but at different 
areas.  When I installed the current RH7 system, I tried to pare down the 
distro to fit the small disk.  I must have left off some critical dev files 
that are necessary for building LFS, and packages in general.
If I am missing something obvious, please let me know, but I think I should 
re-install RH, maybe with 7.2.  Thanks for all the assistance...

Book Version:   3.2 RC1
package:        fileutils-4.1
error-msg:      synopsis follows, full details are at bottom of msg
deviation:      yes, I am trying to build everything in a "static" 
directory using the "Keeping chapter 5 and chapter 6 separate (v0.9)" hint
At 3/2/2002 11:48 AM, you wrote:
>On Fri, Mar 01, 2002 at 09:28:33PM -0500, Richard Brust wrote:
> > gcc: installation problem, cannot exec `as': Cannot allocate memory
> > ../depcomp: /bin/rm: Cannot allocate memory
>How much ram is free when you try to compile it without patching it up? You
>might have to increase your swap.
>Gerard Beekmans
>-*- If Linux doesn't have the solution, you have the wrong problem -*-
>Unsubscribe: send email to listar at
>and put 'unsubscribe lfs-support' in the subject header of the message

Richard Brust
Durham, NH. USA
richard at

Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list