Possible error in chapter 6 bzip2 instructions

wsheldahl at qx.net wsheldahl at qx.net
Wed Mar 6 05:14:59 PST 2002


I want to report an apparent error and workaround I came across last night 
in the chapter 6 instructions for bzip2. I'm just wondering if anyone else has 
come across the same error, or if it was just a freak occurrence on my 

The installation instructions include lots of step-by-step instructions for 
installing, including the following line:

	rm /usr/lib/libbz2.a && 

This line consistently failed; the error was that the file did not exist. After 
redoing it several times and manually checking various other places for 
the file in question, I did the install skipping that step, and it appeared to 
run fine. At least `bzip2 --help` works at this point. Actually, later in the 
session I used the /bin/bzcat created through this install, and it worked 
fine too.

Now the details that might make the problem unique to me. I'm using 
book version 3.2rc1 because that was the current version when I 
started. I checked 3.2rc2 and the cvs book last night, and they both had 
the same instruction in place. I'm also using the "keep chapters 5 and 6 
separate" hint and installing stuff in the order it suggests, instead of the 
book's order. Finally, any time there's a long set of instructions like this, I 
usually put them in a file called "script" with the line "#!/bin/bash" at the 
top, and run it by typing `bash script` at the command prompt. When I 
got it to run successfully, I did so by just commenting out the offending 
line. Saves lots of typing.

Like I said, I was able to work past the problem; I just wanted to see if 
the book was in error, this was a freak occurrence on my system or if 
my system is still slightly messed up and I just don't know it yet (though I 
doubt this). This is my first LFS; I'm doing it on a P90, and only for an 
hour or two each evening, so it will be a while yet before I finish the 

Thanks, everyone!

Wes Sheldahl
wsheldahl at qx.net

Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list