glibc build problem

Mark Binns mbinns at
Sun Mar 10 09:44:29 PST 2002

Hi. I'm using the latest CVS version of the book (9th March) and MSB's
keep_chap5_and_chap6_sep hint and glibc's just choked during the configure
stage. Here's the output from configure:

creating cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking sysdep dirs... sysdeps/i386/elf
linuxthreads/sysdeps/unix/sysv/linux linuxthreads/sysdeps/pthread
sysdeps/pthread linuxthreads/sysdeps/unix/sysv linuxthreads/sysdeps/unix
linuxthreads/sysdeps/i386/i686 linuxthreads/sysdeps/i386
sysdeps/unix/sysv/linux/i386/i686 sysdeps/unix/sysv/linux/i386
sysdeps/unix/sysv/linux sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman
sysdeps/unix/inet sysdeps/unix/sysv/i386 sysdeps/unix/sysv
sysdeps/unix/i386 sysdeps/unix sysdeps/posix sysdeps/i386/i686/fpu
sysdeps/i386/i686 sysdeps/i386/i486 sysdeps/i386/fpu sysdeps/i386
sysdeps/wordsize-32 sysdeps/ieee754/ldbl-96 sysdeps/ieee754/dbl-64
sysdeps/ieee754/flt-32 sysdeps/ieee754 sysdeps/generic/elf sysdeps/generic
checking for a BSD compatible install... /static/bin/install -c
checking whether ln -s works... yes
checking for pwd... /bin/pwd
checking build system type... i686-pc-linux-gnu
checking for gcc... gcc
checking version of gcc... 2.95.3, ok
checking for gnumake... no
checking for gmake... no
checking for make... make
checking version of make... 3.79.1, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... no
checking for makeinfo... makeinfo
checking version of makeinfo... 4.1, ok
checking for gsed... no
checking for sed... sed
checking version of sed... 3.02, ok
checking whether the C compiler (gcc  ) works... no
checking whether the C compiler (gcc  ) is a cross-compiler... (cached)
checking whether we are using GNU C... no
configure: error: GNU libc must be compiled using GNU CC
I have no name!:/usr/src/glibc-build#

The relevant bit of the configure script seems to be putting this in
conftest.c and then trying to run it through cc -E to see if it leaves in
the "yes" (indicating it's gcc). If I run cc -E conftest.c from outside
the chroot (using my base system's gcc) it works fine:

root at rabbit:/mnt/lfs/usr/src/glibc-build# cc -E conftest.c
# 1 "conftest.c"


root at rabbit:/mnt/lfs/usr/src/glibc-build#

But when I run the same command in the chroot I get this:

I have no name!:/usr/src/glibc-build# cc -E conftest.c
cc: installation problem, cannot exec `cpp0': No such file or directory
I have no name!:/usr/src/glibc-build#

Does that mean something was screwed up with the gcc install? I copied the
commands straight out of the book making the change that the keep hint

The only cpp0 I can find is in
$LFS/static/usr/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/ and that's 0 bytes
long. In fact... everything in that directory's 0 bytes long. Erk! (I've
got plenty of space left on the disk too).



Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list