lfs 3.1 compile problems with glibc-2.2.4

maece at tomyum maece at tomyum
Wed Mar 13 12:19:58 PST 2002

I've got some problems compiling the glibc-2.2.4 package.
There's always an error like this:

gcc:internal compiler error: program cc1 got fatal Signal 11
make[2): *** [/usr/src/glibc-buil/stdlib/strtoimax.o] Error 1
make[1]: ***[stdlib/subdir_lib} Error 2
make: ***[all] Error 2

I tried it a lot of times, but without any success. The error is always a signal 11 error, but everytime its another file.
I also tried it without proc mounted (i read it somewhere in the mailing list)
I had an simular error when compiling the gcc package. I solved by booting with mem=32M, because I read something 
about an AMD K6 bug (actually i use an AMD K6-2), that applies with memory greater than 32M.With this boot option it 
wotked well.
But then the above error came up compiling glibc.
When I tried to recompile gcc I've got an error again, though I used the above boot option.
I'm using Suse 7.3 as my primary linux.

Does anybody know something about this problem?



Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list