Problem compiling glibc-2.2.5 with lfs 3.2

Eric ebenze at
Sun Mar 17 19:51:18 PST 2002

Nevermind.  Solved the problem.  Logged back in under a new shell and
everything seems to work fine.  Strange......


"Eric" <ebenze at> wrote in message
news:a73mpj$f2a$1 at
> Hi,
> I'm having trouble compiling glibc-2.2.5 under lfs 3.2.  I have been
> following the steps in the book up until this point, but I am unable to
> compile glibc-2.2.5 (Chapter 6).  I get the following error:
> make[2]: Entering directory '/usr/src/glibc-2.2.5/csu'
> gcc -nostdlib -nostartfiles -r -o /usr/src/glibc-build/csu/crt1.o
> /usr/src/glibc-build/csu/start.o /usr/src/glibc-build/csu/abi-note.o
> /usr/src/glibc-build/csu/init.o
> collect2: cannot find 'ld'
> make[2]: *** [/usr/src/glibc-build/csu/crt1.o] Error 1
> When I check my file structure, indeed I find 'ld' in /usr/bin.  I've also
> checked my path, and ld is in the path.  Finally, just to be sure, i tried
> creating a symlink to /usr/bin/ld in /usr/src/glibc-build/csu.  No
> difference.
> Can anyone point me to a solution please?
> Thanks!
> Eric

Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list