Init doesn't start / ID "1" respawn too fast

helge.brodersen at helge.brodersen at
Tue Mar 19 00:02:33 PST 2002


I have a problem with my LFS which was mentioned here before, but none of the solutions works.
After booting Init starts, that's fine. But then i get the message:
Init version 2.84 booting
Init:Entering runlevel:2
Init:open(/dev/console) Input/Output Error
Init:ID "1" respawn too fast:...
Init:ID "6" respawn too fast:...
Init:No more processes left in this runlevel

(I typed it in from memory, but the message is clear, i think.)
Before compiling Init statically the boot process just stopped before the message "Init version 2.84 booting" and nothing else happens.

The funny thing is:
It all worked well. But on another machine.
LFS was installad on his own HDD. The machine is a Celeron 333. After a little hazzle with IDE, SCSI and LILO everything worked fine on that machine. I build a Kernel for the destination machine, a P90. This new kernel and the whole LFS booted on the celeron. I was happy. To be sure, i put a generic Kernel from my distribution (SuSE 6.2, build for i386) also on the LFS Installation and testet that. It works, too.
Taking the HD into the P90. Result:see before.
Possible problems i excluded:
Inittab is in DOS format. Vi would tell me, as i tested with another file. He didn't.
Does agetty work? Difficult to say. I cannot chroot. The answer is always "Illegal Instruction". But my distribution uses the same glibc as LFS and therefore agetty from the LFS-directory can be started. The login prompt appears.

What else can i do?



-- - meine stadt im netz. Jetzt eigene eMail-adresse sichern!

Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list