Can't compile fileutils in lfs book version 20020325

Rob 'Feztaa' Park feztaa at
Tue Mar 26 19:18:06 PST 2002


I'm using the cvs version from March 25, 2002, and I'm having trouble
compiling fileutils in chapter 5.

The command I used was:

./configure --disable-nls \
   --prefix=$LFS/usr --bindir=$LFS/bin &&
make LDFLAGS=-static &&
make install &&
cd $LFS/usr/bin &&
ln -sf ../../bin/install
and the error I got was:

config.status: linking ./intl/libgettext.h to intl/libintl.h
cd . \
     /bin/sh ./config.status
config.status: creating config.h
config.status: config.h is unchanged
config.status: linking ./intl/libgettext.h to intl/libintl.h
make  all-recursive
make[1]: Entering directory `/mnt/lfs/usr/src/fileutils-4.1'
Making all in lib
make[2]: Entering directory `/mnt/lfs/usr/src/fileutils-4.1/lib'
Makefile:624: *** missing separator.  Stop.
make[2]: Leaving directory `/mnt/lfs/usr/src/fileutils-4.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/lfs/usr/src/fileutils-4.1'
make: *** [all] Error 2

Any thoughts? I've tried this with and without the patch for
amd/glibc-2.2.3, and I get the same error (which doesn't surprize me
because I'm using a pentium2 with glibc-2.2.4).

The 'distro' that I'm using to install this from is lfs, cvs version


Rob 'Feztaa' Park
feztaa at
Apathy Club meeting this Friday.  If you want to come, you're not invited.
Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list