Java Support?

Eric ebenze at
Fri Mar 29 16:55:08 PST 2002

Ahh... there's the catch.  I was trying to compile from a source tar ball.

I ended up downloading a binary and installing it, and adding a symlink from to

And it worked.  THe problem I was having with compiling the J2ME micro
edition was the version of gcc wasn't working for some reason.  Used an
older version, and we're golden.



"Paul" <dazzle750 at> wrote in message
news:3CA4AFCD.1060200 at
> I didn't compile Java from source!
> Download the "Linux GNUZIP Tar shell script"
> chmod +x j2sdk-x_x_x-linux-i386.bin  (where x_x_x is the version number)
> su
> ./j2sdk-x_x_x_-linux-i386.bin
> This should now unpack itself to jdkx.x.x in which ever directory you
> downloaded it to. You can then move the folder to wherever you want.
> I've got mine in /usr/share/java/jdk - I renamed the jdk1.3.1 folder to
> The entries you need in your .bash_profile are:
> JAVA_HOME=/usr/share/java/jdk/jre
> rcesSamples.jar:/usr/share/java/fop/fop.jar
> Then add to your export list:
> JAVA_HOME is the file path to where ever you have the jdk folder and
> points to the runtime folder, jre, within that
> CLASSPATH is any folder which holds Java executables or .jar files. In
> the list above you will only need the first two entries, the other
> entries are extra Java packages I've downloaded.
> I know how to do this from having set the Java SDK up on Windows - it
> follows the same procedure, but you are right the documentation / set-up
> info. is almost non existent.
> Also don't remember having a problem with the libs but try creating a
> symlink:
> su
> cd /usr/lib
> ln -s
> hope this helps,
> Paul
> Eric wrote:
> > Hi,
> >
> > I'm trying to install the Java Micro Edition in my LFS 3.2 system, but
> > running into a small problem.  Unfortunately, to compile the J2ME
> > you need the Java 2 SDK.  The SDK seems to be huge to compile on its own
> > (and badly documented), so I've tried to circumvent the issue by using
> > binary RPM.  Of course, that's where I start to run into problems.
> >
> > My initial system that I used to create my LFS system was a Redhat 7.2.
> > d'led the SDK rpm and installed it on my original RedHat install.  Now,
> > trying to compile the Micro Edition in my LFS, but it complains that I
> > have the right libraries (is looking for glibc 6.1.1).  Of course, LFS
> > is libc6.2.2.
> >
> > Any idea how I can get around this problem?  Has anyone installed Java
> > support in their LFS system?  Can you please give me tips/pointers on
> >
> > Thanks!
> >
> > Eric
> >
> >
> >

Unsubscribe: send email to listar at
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list