GRUB working *very* slow

Matt Bartley mbartley2 at
Fri Aug 6 22:25:36 PDT 2004

I've been troubleshooting a computer system which I suspect has a 
flaking-out hard disk.  I figured a good test would be to put a 
different disk in there and try it out.

I figured a good way to do this was to install LFS on one of my old 
disks and then move it over to the test computer.  I built 
6.0-testing-20040801 on that disk while it was plugged into my computer.  
After I finished and confirmed it worked, I moved it over to the test 
computer and tried it there.

I had to boot Knoppix and use that to mount the LFS disk to edit 
/etc/fstab and use rdev to adjust the kernel's expected root filesystem.  
When I boot the disk, I get this message:

GRUB Loading stage1.5.

<~35 second delay, no disk activity>

GRUB loading, please wait...

<~35 second delay, no disk activity>

Then it finally goes into the expected boot menu and everything works 
from there.

What's going on here?  This disk boots perfectly on my computer.

My computer: 1.5 GHz Athlon-XP, SiS chipset motherboard

His computer: 1 GHz Athlon, Via chipset motherboard

More information about the lfs-support mailing list