Rebooting the system

FRED MSUMENO fredmsumeno at
Mon Aug 9 05:39:54 PDT 2004


I have tried to change my /etc/fstab file  as suggested below I still get the same failures in rebooting my new lfs system , I also have tried to check and change some other files I'm getting same errors or increase number of errors 

Please any further help of what is wrong !  or what options should I do in my files?


Date: Wed, 4 Aug 2004 23:15:15 +0200
From: Thomas Hackert 
Subject: Re: Rebooting the system
Cc: lfs-support at
Message-ID: <200408042315.15494.thackert at>
Content-Type: text/plain; charset="iso-8859-15"

Hi Fred,
On Mittwoch, 4. August 2004 09:29, you wrote:
> -mount:can't find / in /etc/fstab or /etc/mtab .......FAILED
> -mount:can not remove /var/run/utmp :Read only file system
> ...........FAILED
> -Recording exiting mounts in etc/mtab ........
> /etc/rc/rcsysinit.d/s40mountfs: line 17: /etc/mtab:Readonly file
> system mount: can't find / in /etc/fstab or etc/mtab
> ......FAILED
> -mount:mounting remain file system .... FAILED
> rm:Removing /var/run/* and /var/lock/* ....... FAILED
> Starting system log daemon .... FAILED
These are only messages, that your partition seems to be read-only.

> Here is my /etc/fstab as it looks in my new system
> # Begin /etc/fstab
> # file system mount-point fs-type options 
> dump fsck-order
> /dev/hda5 / old-distro ext3 noauto 
This here ^^^^^^^ should be /old-distro & ^^^ should be 
defaults ... I think this is the reason for the "read-only file 
system"-messages above ... Maybe I am wrong here and some of the 
others could correct me ... ;)

> 1 1 /dev/hda6 swap swap 
> pri=1 0 0 proc /proc 
> proc defaults 0 0 devpts
> /dev/pts devpts gid=4,mode=620 0 
> 0 shm /dev/shm tmpfs defaults 
> 0 0
> # End /etc/fstab
> However in chapter 2 ,(creating a new partion ) I used hint from
> (
>_existing_systems.txt) so the first line in /etc/fstab is changed
> accordingly.
I have skimmed through it here and there I have seen the above 
mentioned /old-distro. Although Matthias mentioned the noauto entry 
in fstab, I think jfs should be defaulted ...

> Also there is another failure which is not related to /etc/fstab
> -----Starting system log daemon .... FAILED
> please in your reply let me know also about it
Like I said above: Your file system is read-only. Log daemons are 
normally configured to log a lot of stuff to some files and if they 
can not write to it, they fail to start ...

> Thanks in advance .
I hope I made it a bit clearer and my English is understandable 

Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lfs-support mailing list