LFS-5.1.1 Ch.6 - Util-linux-2.12a build problems

Omar Silva Sarabia osilva at eyenet.com.mx
Wed Aug 18 16:21:15 PDT 2004


As stated earlier on Chapter 6:

A few kernel header files refer to the autoconf.h header file. Since we have
not yet configured the kernel, we need
to create this file ourselves in order to avoid a compilation failure of
Sysklogd. Create an empty autoconf.h file
touch /usr/include/linux/autoconf.h

in your case:

toucn /ktools/ include/linux/autoconf.h

This will work for you, I have this problem but I realized until I reboot
the system and cannot mount any filesystem, the mount were missed.

I hope this helps.

-----Mensaje original-----
De: lfs-support-bounces at linuxfromscratch.org
[mailto:lfs-support-bounces at linuxfromscratch.org] En nombre de Jan Mattila
Enviado el: Miércoles, 18 de Agosto de 2004 05:41 p.m.
Para: lfs-support at linuxfromscratch.org
Asunto: LFS-5.1.1 Ch.6 - Util-linux-2.12a build problems


I've beed going by the book LFS-5.1.1 and have had no significant 
problems until Ch. 6 Util-linux-2.12a make gave me this:

# make HAVE_KILL=yes HAVE_SLN=yes
make[1]: Entering directory `/src/u/util-linux-2.12a/hwclock'
cc -c -pipe -O2 -mcpu=i486 -fomit-frame-pointer -I../lib -Wall
-Wmissing-prototypes -Wstrict-prototypes -DNCH=1   -D_FILE_OFFSET_BITS=64
-DSBINDIR=\"/sbin\" -DUSRSBINDIR=\"/usr/sbin\" -DLOGDIR=\"/var/log\"
-DVARPATH=\"/var\" -DLOCALEDIR=\"/usr/share/locale\" -O2 hwclock.c -o
cc -pipe -O2 -mcpu=i486 -fomit-frame-pointer -I../lib -Wall 
-Wstrict-prototypes -DNCH=1   -D_FILE_OFFSET_BITS=64 -DSBINDIR=\"/sbin\"
-DUSRSBINDIR=\"/usr/sbin\" -DLOGDIR=\"/var/log\" -DVARPATH=\"/var\"
-DLOCALEDIR=\"/usr/share/locale\" -O2 -c cmos.c -o cmos.o
In file included from /ktools/include/asm/io.h:4,
                 from cmos.c:53:
/ktools/include/linux/config.h:4:28: linux/autoconf.h: No such file or
make[1]: *** [cmos.o] Error 1
make[1]: Leaving directory `/src/u/util-linux-2.12a/hwclock'
make: *** [all] Error 1

It's treu there is no autoconf.h in /ktools/include/linux. There
is however one in /usr/include/linux/autoconf.h just like I think 
there's supposed to be, but I can't seem to tell that to Util-linux. 
I've tried changing line 53 in cmos.c from <asm/io.h> 
to </usr/include/asm/io.h> but that only resulted in:

In file included from /usr/include/asm/io.h:4,
                 from cmos.c:53:
/ktools/include/linux/config.h:4:28: linux/autoconf.h: No such file or
make[1]: *** [cmos.o] Error 1
make[1]: Leaving directory `/src/u/util-linux-2.12a/hwclock'
make: *** [all] Error 1

Also, the configure says that 

cannot find any C preprocessor (cpp)
Your rpcgen output does not compile - using pregenerated code
You don't have zlib

Although I have libz.so in both /usr/lib and libz.so.1 in /lib,
by the book.

Possible sources of problems:

I've used /ktools instead of /tools, because I've been building
an HLFS-system on the side until I ran into problems with that.
I've used /ktools consistently, so that shouldn't count as 
deviating from the book unless the /tools is hardcoded into some
of the patches or something like that. I've also used separate
alphabetical directories under src/ for storing the sources, which 
has had me double checking every relative directory move (since 
../ in the book would usually be ../../ for me...), but I'm pretty 
sure I haven't missed anything. At least I think that I should 
have failed some make checks or make tests if I had messed up the 
relative subdirectories. The only checks that I've failed are 
2 math test from Glibc-2.3.3-lfs-5.1 but I've googled that they 
are due to my processor not being good at counting and that they
are nothing to worry about. Other than that all tests and checks
have passed.

My initial build system is based on LFS-3.3, I've only upgraded
my kernel. I think my initial build system shuoldn't matter in
Ch. 6, but here are some specs anyway:

# uname -a
Linux terry 2.4.26 #1 to elo  5 14:17:10 EEST 2004 i586 unknown

# gcc -dumpversion

# gcc -dumpmachine

# /lib/libc.so.6
GNU C Library stable release version 2.2.5<snip>

# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 5
model           : 13
model name      : AMD-K6(tm)-III Processor
stepping        : 4
cpu MHz         : 501.155

I'll be happy to provide any more detailed information to help 
debug this curious Util-linux-2.12a problem. I'm a little anxious 
about continuing with the build before the problem is solved at
least to some extent.


 Jan Mattila <jan.mattila at helsinki.fi>

 "Finland, Finland, Finland, Finland has it all."
                             - Michael Palin
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

More information about the lfs-support mailing list